$re = '/<bean:write[^\/]*\/>/';
$str = '<input name="id" type="radio" bgcolor="<bean:write name=\'color\'/>" value="<bean:write name=\'nameProp\' property=\'nameVal\'/>" <logic:equal name="checkedStatus" value="0">checked</logic:equal>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);