use strict;
my $str = 'Hello World
HELLo World';
my $regex = qr/([A-Z]+)/mp;
my $subst = '1$11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";