import Foundation
let pattern = #"([A-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello World
HELLo World
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1$11"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)