using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^if|^while|[ ;}\n]if|while)[ ]*([(]([^()]|(?2))*[)])";
string input = @"if(something)
while(somethin*(sdds(d)(f)f(s)e))gif(sine)
hile()
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}