re = /(^if|^while|[ ;}\n]if|while)[ ]*([(]([^()]|(?2))*[)])/
str = 'if(something)
while(somethin*(sdds(d)(f)f(s)e))gif(sine)
hile()
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end