$re = '/(^if|^while|[ ;}\n]if|while)[ ]*([(]([^()]|(?2))*[)])/';
$str = 'if(something)
while(somethin*(sdds(d)(f)f(s)e))gif(sine)
hile()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);