// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^if|^while|[ ;}\n]if|while)[ ]*([(]([^()]|(?2))*[)])").unwrap();
let string = "if(something)
while(somethin*(sdds(d)(f)f(s)e))gif(sine)
hile()
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}