const regex = new RegExp('# you define first the basic elements (as for a lexer) with named groups
(?(DEFINE)
(?<var> [a-z_]\\w*)
(?<dqstr> (?<=") [^\\\\"]*+ (?s:\\\\.[^\\\\"]*)*+ (?=") )
(?<sqstr> (?<=\\') [^\\\\\\']*+ (?s:\\\\.[^\\\\\\']*)*+ (?=\\') )
(?<string> \\g<dqstr> | \\g<sqstr> )
(?<num> [0-9]+(?:\\.[0-9]+)? )
(?<value> \\g<string> | \\g<num> )
(?<comp> [!><=]= | =?[><])
)
# Then you write the pattern using these named groups
(?J) # allow duplicate named groups
# variable op value
(?<key> \\g<var> ) \\h* \\g<comp> \\h* ["\\']?(?<val> \\g<value>) ["\\']?
| # OR
# value op variable
["\\']?(?<val> \\g<value>) ["\\']? \\h* \\g<comp> \\h* (?<key> \\g<var> )
', 'gi')
const str = `type == 'prova' && padposition == "stefano" or 10>var_name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}