import Foundation
let pattern = ##"""
# you define first the basic elements (as for a lexer) with named groups
(?(DEFINE)
(?<var> [a-z_]\w*)
(?<dqstr> (?<=") [^\\"]*+ (?s:\\.[^\\"]*)*+ (?=") )
(?<sqstr> (?<=') [^\\']*+ (?s:\\.[^\\']*)*+ (?=') )
(?<string> \g<dqstr> | \g<sqstr> )
(?<num> [0-9]+(?:\.[0-9]+)? )
(?<value> \g<string> | \g<num> )
(?<comp> [!><=]= | =?[><])
)
# Then you write the pattern using these named groups
(?J) # allow duplicate named groups
# variable op value
(?<key> \g<var> ) \h* \g<comp> \h* ["']?(?<val> \g<value>) ["']?
| # OR
# value op variable
["']?(?<val> \g<value>) ["']? \h* \g<comp> \h* (?<key> \g<var> )
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"type == 'prova' && padposition == "stefano" or 10>var_name"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)