import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:729)?0*?123(?:[\\x{00BF}-\\x{1FFF}\\x{2C00}-\\x{D7FF}a-zA-Z])*\\.(?:jpg|png))";
final String string = "123.jpg\n"
+ "123× ×™×¡×™×•×Ÿ.jpg\n"
+ "123.jpg\n"
+ "729000123× ×™×¡×™×•×Ÿ.jpg\n"
+ "729000123test.jpg\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}