$re = '/^((?:729)?0*?123(?:[\x{00BF}-\x{1FFF}\x{2C00}-\x{D7FF}a-zA-Z])*\.(?:jpg|png))/m';
$str = '123.jpg
123× ×™×¡×™×•×Ÿ.jpg
123.jpg
729000123× ×™×¡×™×•×Ÿ.jpg
729000123test.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);