const regex = /^((?:729)?0*?123(?:[\x{00BF}-\x{1FFF}\x{2C00}-\x{D7FF}a-zA-Z])*\.(?:jpg|png))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:729)?0*?123(?:[\\x{00BF}-\\x{1FFF}\\x{2C00}-\\x{D7FF}a-zA-Z])*\\.(?:jpg|png))', 'gm')
const str = `123.jpg
123× ×™×¡×™×•×Ÿ.jpg
123.jpg
729000123× ×™×¡×™×•×Ÿ.jpg
729000123test.jpg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}