import re
regex = re.compile(r"^((?:729)?0*?123(?:[\x{00BF}-\x{1FFF}\x{2C00}-\x{D7FF}a-zA-Z])*\.(?:jpg|png))", flags=re.MULTILINE)
test_str = ("123.jpg\n"
"123× ×™×¡×™×•×Ÿ.jpg\n"
"123.jpg\n"
"729000123× ×™×¡×™×•×Ÿ.jpg\n"
"729000123test.jpg\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")