#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:10\.\d{1,3}\.\d{1,3}\.\d{1,3}|172\.(?:(?:1[6-9])|(?:2[0-9])|(?:3[0-1]))\.\d{1,3}\.\d{1,3}|192\.168\.\d{1,3}\.\d{1,3}|127\.\d{1,3}\.\d{1,3}\.\d{1,3})(?::\d{1,5})?)$"
Local $sString = "127.0.0.1" & @CRLF & _
"127.255.255.255" & @CRLF & _
"127.0.0.1:3000" & @CRLF & _
"10.0.0.1" & @CRLF & _
"10.0.0.2" & @CRLF & _
"10.0.1.1" & @CRLF & _
"10.0.1.2:443" & @CRLF & _
"172.16.0.1" & @CRLF & _
"172.16.0.2" & @CRLF & _
"172.16.1.1" & @CRLF & _
"172.16.1.2" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.168.0.2" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.2" & @CRLF & _
"10.10.10.1" & @CRLF & _
"10.10.10.2" & @CRLF & _
"172.31.255.1" & @CRLF & _
"172.31.255.2" & @CRLF & _
"192.168.100.1" & @CRLF & _
"192.168.100.2" & @CRLF & _
"10.255.255.1" & @CRLF & _
"10.255.255.2" & @CRLF & _
"8.8.8.8:80" & @CRLF & _
"1.1.1.1" & @CRLF & _
"1.0.0.1" & @CRLF & _
"198.41.0.4" & @CRLF & _
"64.233.160.0" & @CRLF & _
"208.67.222.222:8080"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")