import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:10\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|172\\.(?:(?:1[6-9])|(?:2[0-9])|(?:3[0-1]))\\.\\d{1,3}\\.\\d{1,3}|192\\.168\\.\\d{1,3}\\.\\d{1,3}|127\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})(?::\\d{1,5})?)$";
final String string = "127.0.0.1\n"
+ "127.255.255.255\n"
+ "127.0.0.1:3000\n"
+ "10.0.0.1\n"
+ "10.0.0.2\n"
+ "10.0.1.1\n"
+ "10.0.1.2:443\n"
+ "172.16.0.1\n"
+ "172.16.0.2\n"
+ "172.16.1.1\n"
+ "172.16.1.2\n"
+ "192.168.0.1\n"
+ "192.168.0.2\n"
+ "192.168.1.1\n"
+ "192.168.1.2\n"
+ "10.10.10.1\n"
+ "10.10.10.2\n"
+ "172.31.255.1\n"
+ "172.31.255.2\n"
+ "192.168.100.1\n"
+ "192.168.100.2\n"
+ "10.255.255.1\n"
+ "10.255.255.2\n"
+ "8.8.8.8:80\n"
+ "1.1.1.1\n"
+ "1.0.0.1\n"
+ "198.41.0.4\n"
+ "64.233.160.0\n"
+ "208.67.222.222:8080";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}