import re
regex = re.compile(r"^(?:(?:10\.\d{1,3}\.\d{1,3}\.\d{1,3}|172\.(?:(?:1[6-9])|(?:2[0-9])|(?:3[0-1]))\.\d{1,3}\.\d{1,3}|192\.168\.\d{1,3}\.\d{1,3}|127\.\d{1,3}\.\d{1,3}\.\d{1,3})(?::\d{1,5})?)$", flags=re.MULTILINE)
test_str = ("127.0.0.1\n"
"127.255.255.255\n"
"127.0.0.1:3000\n"
"10.0.0.1\n"
"10.0.0.2\n"
"10.0.1.1\n"
"10.0.1.2:443\n"
"172.16.0.1\n"
"172.16.0.2\n"
"172.16.1.1\n"
"172.16.1.2\n"
"192.168.0.1\n"
"192.168.0.2\n"
"192.168.1.1\n"
"192.168.1.2\n"
"10.10.10.1\n"
"10.10.10.2\n"
"172.31.255.1\n"
"172.31.255.2\n"
"192.168.100.1\n"
"192.168.100.2\n"
"10.255.255.1\n"
"10.255.255.2\n"
"8.8.8.8:80\n"
"1.1.1.1\n"
"1.0.0.1\n"
"198.41.0.4\n"
"64.233.160.0\n"
"208.67.222.222:8080")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")