// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:10\.\d{1,3}\.\d{1,3}\.\d{1,3}|172\.(?:(?:1[6-9])|(?:2[0-9])|(?:3[0-1]))\.\d{1,3}\.\d{1,3}|192\.168\.\d{1,3}\.\d{1,3}|127\.\d{1,3}\.\d{1,3}\.\d{1,3})(?::\d{1,5})?)$").unwrap();
let string = "127.0.0.1
127.255.255.255
127.0.0.1:3000
10.0.0.1
10.0.0.2
10.0.1.1
10.0.1.2:443
172.16.0.1
172.16.0.2
172.16.1.1
172.16.1.2
192.168.0.1
192.168.0.2
192.168.1.1
192.168.1.2
10.10.10.1
10.10.10.2
172.31.255.1
172.31.255.2
192.168.100.1
192.168.100.2
10.255.255.1
10.255.255.2
8.8.8.8:80
1.1.1.1
1.0.0.1
198.41.0.4
64.233.160.0
208.67.222.222:8080";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}