#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{31})[a-z]+(?:-[a-z]+)*$"
Local $sString = "TRUE" & @CRLF & _
"a-b" & @CRLF & _
"ab-cd" & @CRLF & _
"abc" & @CRLF & _
"a-b-c" & @CRLF & _
"" & @CRLF & _
"FALSE" & @CRLF & _
"a-" & @CRLF & _
"-a" & @CRLF & _
"a--b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")