re = /^(?!.{31})[a-z]+(?:-[a-z]+)*$/m
str = 'TRUE
a-b
ab-cd
abc
a-b-c
FALSE
a-
-a
a--b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end