using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{31})[a-z]+(?:-[a-z]+)*$";
string input = @"TRUE
a-b
ab-cd
abc
a-b-c
FALSE
a-
-a
a--b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}