$re = '/^(?!.{31})[a-z]+(?:-[a-z]+)*$/m';
$str = 'TRUE
a-b
ab-cd
abc
a-b-c
FALSE
a-
-a
a--b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);