import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{31})[a-z]+(?:-[a-z]+)*$";
final String string = "TRUE\n"
+ "a-b\n"
+ "ab-cd\n"
+ "abc\n"
+ "a-b-c\n\n"
+ "FALSE\n"
+ "a-\n"
+ "-a\n"
+ "a--b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}