package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(-?[0-9]+)\s([0-9A-Z]+)\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s-?([UPFO])\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s([-,A-F,T])\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})`)
var str = `9 194C 26-Sep-2014 F 13-Oct-2014 B -183123.00 -3663.00 -3663.00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}