import Foundation
let pattern = #"^(-?[0-9]+)\s([0-9A-Z]+)\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s-?([UPFO])\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s([-,A-F,T])\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"9 194C 26-Sep-2014 F 13-Oct-2014 B -183123.00 -3663.00 -3663.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}