import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?[0-9]+)\\s([0-9A-Z]+)\\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\\s-?([UPFO])\\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\\s([-,A-F,T])\\s(-?[0-9]+\\.[0-9]{2})\\s(-?[0-9]+\\.[0-9]{2})\\s(-?[0-9]+\\.[0-9]{2})";
final String string = "9 194C 26-Sep-2014 F 13-Oct-2014 B -183123.00 -3663.00 -3663.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}