$re = '/^(-?[0-9]+)\s([0-9A-Z]+)\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s-?([UPFO])\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s([-,A-F,T])\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})/';
$str = '9 194C 26-Sep-2014 F 13-Oct-2014 B -183123.00 -3663.00 -3663.00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);