use strict;
my $str = '9 194C 26-Sep-2014 F 13-Oct-2014 B -183123.00 -3663.00 -3663.00';
my $regex = qr/^(-?[0-9]+)\s([0-9A-Z]+)\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s-?([UPFO])\s(-?[0-9]{2}-[a-zA-Z]{3}-[0-9]{4})\s([-,A-F,T])\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})\s(-?[0-9]+\.[0-9]{2})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}