import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https://github\\.com/)?(?P<namespace>[^/\\s]+)\\/(?P<repo>[^#\\s]+)(#|/pull/)(?P<pr_id>\\d+)";
final String string = "/packit-dev test --identifier my-id-1 --labels label1,label2 namespace-1/repo-1#33\n"
+ "/packit-dev test namespace-2/repo-2#36 --identifier my-id-2\n"
+ "/packit-dev test namespace-2/repo-2#36 --labels label1 --identifier my-id-2\n"
+ "/packit-dev test namespace-2/repo-2#36 --labels label1 --id my-id-2\n"
+ "/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2\n"
+ "/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2 \n"
+ "/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE=bundle --labels label1\n"
+ "/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE= --labels label1\n"
+ "/packit-dev test https://github.com/kontura/librepo/pull/4\n"
+ "/packit-dev test https://github.com/namespace-3/repo-3/pull/42 --identifier my-id-3\n"
+ "/packit-dev test --labels label1,label2 https://github.com/namespace-4/repo-4/pull/99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}