// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https://github\.com/)?(?P<namespace>[^/\s]+)\/(?P<repo>[^#\s]+)(#|/pull/)(?P<pr_id>\d+)").unwrap();
let string = "/packit-dev test --identifier my-id-1 --labels label1,label2 namespace-1/repo-1#33
/packit-dev test namespace-2/repo-2#36 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --id my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE=bundle --labels label1
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE= --labels label1
/packit-dev test https://github.com/kontura/librepo/pull/4
/packit-dev test https://github.com/namespace-3/repo-3/pull/42 --identifier my-id-3
/packit-dev test --labels label1,label2 https://github.com/namespace-4/repo-4/pull/99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}