import Foundation
let pattern = ##"(https://github\.com/)?(?P<namespace>[^/\s]+)\/(?P<repo>[^#\s]+)(#|/pull/)(?P<pr_id>\d+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/packit-dev test --identifier my-id-1 --labels label1,label2 namespace-1/repo-1#33
/packit-dev test namespace-2/repo-2#36 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --id my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE=bundle --labels label1
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE= --labels label1
/packit-dev test https://github.com/kontura/librepo/pull/4
/packit-dev test https://github.com/namespace-3/repo-3/pull/42 --identifier my-id-3
/packit-dev test --labels label1,label2 https://github.com/namespace-4/repo-4/pull/99
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)