using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}(\d{3})\1";
string input = @"Note - I don't need spaces in between. Pattern 1: Number: 3527432432 Let's consider the above number as ABCD XYZ XYZ pattern
Pattern 2: Number: 3527898989 ABCD XY XY XY
Pattern 3: Number: 3535358745 XY XY XY ABCD
Pattern 4: 5432888999 ABCD XXX YYY
Pattern 5: 5432888899 ABCD XXXX YY
Pattern 65432334422 ABCD XX YY ZZ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}