const regex = new RegExp('\\d{4}(\\d{3})\\1', 'gm')
const str = `Note - I don't need spaces in between. Pattern 1: Number: 3527432432 Let's consider the above number as ABCD XYZ XYZ pattern
Pattern 2: Number: 3527898989 ABCD XY XY XY
Pattern 3: Number: 3535358745 XY XY XY ABCD
Pattern 4: 5432888999 ABCD XXX YYY
Pattern 5: 5432888899 ABCD XXXX YY
Pattern 65432334422 ABCD XX YY ZZ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}