re = /\d{4}(\d{3})\1/m
str = 'Note - I don\'t need spaces in between. Pattern 1: Number: 3527432432 Let\'s consider the above number as ABCD XYZ XYZ pattern
Pattern 2: Number: 3527898989 ABCD XY XY XY
Pattern 3: Number: 3535358745 XY XY XY ABCD
Pattern 4: 5432888999 ABCD XXX YYY
Pattern 5: 5432888899 ABCD XXXX YY
Pattern 65432334422 ABCD XX YY ZZ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end