import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}(\\d{3})\\1";
final String string = "Note - I don't need spaces in between. Pattern 1: Number: 3527432432 Let's consider the above number as ABCD XYZ XYZ pattern\n\n"
+ "Pattern 2: Number: 3527898989 ABCD XY XY XY\n\n"
+ "Pattern 3: Number: 3535358745 XY XY XY ABCD\n\n"
+ "Pattern 4: 5432888999 ABCD XXX YYY\n\n"
+ "Pattern 5: 5432888899 ABCD XXXX YY\n\n"
+ "Pattern 65432334422 ABCD XX YY ZZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}