use strict;
my $str = 'Note - I don\'t need spaces in between. Pattern 1: Number: 3527432432 Let\'s consider the above number as ABCD XYZ XYZ pattern
Pattern 2: Number: 3527898989 ABCD XY XY XY
Pattern 3: Number: 3535358745 XY XY XY ABCD
Pattern 4: 5432888999 ABCD XXX YYY
Pattern 5: 5432888899 ABCD XXXX YY
Pattern 65432334422 ABCD XX YY ZZ';
my $regex = qr/\d{4}(\d{3})\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}