#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(https?:\/\/[^\/]+)\/[0-9]{6}(\/\S*)"
Local $sString = "http://webdomain.com/123456/name-of-a-post/" & @CRLF & _
"" & @CRLF & _
"I would like to create a redirect rule that will point the incoming traffic to this permalink scenario:" & @CRLF & _
"" & @CRLF & _
"http://webdomain.com/name-of-a-post/"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)