// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(https?:\/\/[^\/]+)\/[0-9]{6}(\/\S*)").unwrap();
let string = "http://webdomain.com/123456/name-of-a-post/
I would like to create a redirect rule that will point the incoming traffic to this permalink scenario:
http://webdomain.com/name-of-a-post/";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}