const regex = /(https?:\/\/[^\/]+)\/[0-9]{6}(\/\S*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/[^\\\/]+)\\\/[0-9]{6}(\\\/\\S*)', 'gmi')
const str = `http://webdomain.com/123456/name-of-a-post/
I would like to create a redirect rule that will point the incoming traffic to this permalink scenario:
http://webdomain.com/name-of-a-post/`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);