import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/[^\\/]+)\\/[0-9]{6}(\\/\\S*)";
final String string = "http://webdomain.com/123456/name-of-a-post/\n\n"
+ "I would like to create a redirect rule that will point the incoming traffic to this permalink scenario:\n\n"
+ "http://webdomain.com/name-of-a-post/";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}