$re = '/(https?:\/\/[^\/]+)\/[0-9]{6}(\/\S*)/mi';
$str = 'http://webdomain.com/123456/name-of-a-post/
I would like to create a redirect rule that will point the incoming traffic to this permalink scenario:
http://webdomain.com/name-of-a-post/';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;