#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(error|warning) at line (\d+), column (\d+), file \((C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523\.pddl|C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw\.pddl)\)\s*:\s*(.+)"
Local $sString = "Parser error at line 17, column 38, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 19, column 18, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 31, column 7, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 4, column 59, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 5, column 3, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 5, column 15, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 5, column 27, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"Parser error at line 5, column 39, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined" & @CRLF & _
"parse files "C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl" and "C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl": no ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")