import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(error|warning) at line (\\d+), column (\\d+), file \\((C:\\\\Users\\\\user\\\\AppData\\\\Local\\\\Temp\\\\domain-86428y6XVxOfw6523\\.pddl|C:\\\\Users\\\\user\\\\AppData\\\\Local\\\\Temp\\\\problem-86428UP0ka6cCyWMw\\.pddl)\\)\\s*:\\s*(.+)";
final String string = "Parser error at line 17, column 38, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 19, column 18, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 31, column 7, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 4, column 59, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 5, column 3, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 5, column 15, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 5, column 27, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
+ "Parser error at line 5, column 39, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
+ "parse files \"C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl\" and \"C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl\": no ok";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}