import re
regex = re.compile(r"(error|warning) at line (\d+), column (\d+), file \((C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523\.pddl|C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw\.pddl)\)\s*:\s*(.+)")
test_str = ("Parser error at line 17, column 38, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 19, column 18, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 31, column 7, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 4, column 59, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 5, column 3, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 5, column 15, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 5, column 27, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
"Parser error at line 5, column 39, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate \"ontable/1\" is undefined\n"
"parse files \"C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl\" and \"C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl\": no ok")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")