package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(error|warning) at line (\d+), column (\d+), file \((C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523\.pddl|C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw\.pddl)\)\s*:\s*(.+)`)
var str = `Parser error at line 17, column 38, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 19, column 18, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 31, column 7, file (C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 4, column 59, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 3, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 15, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 27, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 39, file (C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
parse files "C:\Users\user\AppData\Local\Temp\domain-86428y6XVxOfw6523.pddl" and "C:\Users\user\AppData\Local\Temp\problem-86428UP0ka6cCyWMw.pddl": no ok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}