const regex = /(error|warning) at line (\d+), column (\d+), file \((C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523\.pddl|C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw\.pddl)\)\s*:\s*(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(error|warning) at line (\\d+), column (\\d+), file \\((C:\\\\Users\\\\user\\\\AppData\\\\Local\\\\Temp\\\\domain-86428y6XVxOfw6523\\.pddl|C:\\\\Users\\\\user\\\\AppData\\\\Local\\\\Temp\\\\problem-86428UP0ka6cCyWMw\\.pddl)\\)\\s*:\\s*(.+)', 'g')
const str = `Parser error at line 17, column 38, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 19, column 18, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 31, column 7, file (C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl) : predicate "ontable/1" is undefined
Parser error at line 4, column 59, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 3, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 15, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 27, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
Parser error at line 5, column 39, file (C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl) : predicate "ontable/1" is undefined
parse files "C:\\Users\\user\\AppData\\Local\\Temp\\domain-86428y6XVxOfw6523.pddl" and "C:\\Users\\user\\AppData\\Local\\Temp\\problem-86428UP0ka6cCyWMw.pddl": no ok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}