const regex = /(?=\b\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\b\\d)', 'g')
const str = `Something something something 30min`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);