import Foundation
let pattern = #"(?=\b\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Something something something 30min"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)