$re = '/(?=\b\d)/';
$str = 'Something something something 30min';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;