re = /(?=\b\d)/
str = 'Something something something 30min'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result