use strict;
my $str = 'Something something something 30min';
my $regex = qr/(?=\b\d)/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";